#Excel – Come sommare ogni n colonne

Per sommare ogni n colonne, è possibile utilizzare una formula basata sulle funzioni MATR.SOMMA.PRODOTTO, RESTO e RIF.COLONNA.

Sommare ogni n colonne

Nell’esempio mostrato, la formula in cella L3 è la seguente:

=MATR.SOMMA.PRODOTTO(--(RESTO(RIF.COLONNA(B3:J3)-RIF.COLONNA(B3)+1;K3)=0);B3:J3)

Come funziona questa formula

Sinteticamente, essa utilizza MATR.SOMMA.PRODOTTO per sommare i valori della riga che sono stati “filtrati” usando la logica basata su RESTO. La chiave è questa:

RESTO(RIF.COLONNA(B3:J3)-RIF.COLONNA(B3)+1;K3)=0

Questo segmento della formula utilizza la funzione RIF.COLONNA per ottenere un insieme di numeri di colonna “relativi” per l’intervallo, ottenendo un risultato simile a questo:

{123456789}

Questa matrice entra nella funzione RESTO in questo modo:

RESTO({123456789};K3)=0

dove K3 è il valore di n per la riga 3. La funzione RESTO restituisce il resto per ogni numero di colonna diviso per n. Così, per esempio, quando n = 3, RESTO restituirà qualcosa di simile a questo:

{121212}

Si noti che gli zeri appaiono per le colonne 3, 6, 9, ecc La formula utilizza = 0 per forzare un VERO quando il resto è zero e un FALSO quando non lo è, allora usiamo un doppio negativo () per trasformare VERO e FALSO in 1 e 0. Ottenendo una matrice simile a questa:

{0111}

Dove gli 1 ora indicano gli “ennesimi valori”. Questo va in MATR.SOMMA.PRODOTTO come matrice1, insieme a B3:J3 come matrice2. MATR.SOMMA.PRODOTTO poi fa il suo dovere, prima moltiplicando, quindi sommando i prodotti delle matrici.

Gli unici valori che “sopravvivono” alla moltiplicazione sono quelli in cui matrice1 contiene 1. È come se matrice1 filtrasse i valori di matrice2.

Sommare colonne alternate

Se volete sommare colonne alternate, basta adattare questa formula, se necessario, tenendo presente che la formula assegna automaticamente 1 alla prima colonna nell’intervallo. Per sommare le colonne PARI, usate:

=MATR.SOMMA.PRODOTTO(--(RESTO(RIF.COLONNA(B3:J3)-RIF.COLONNA(B3)+1;2)=0);B3:J3)

mentre per le colonne DISPARI:

=MATR.SOMMA.PRODOTTO(--(RESTO(RIF.COLONNA(B3:J3)-RIF.COLONNA(B3)+1;2)=1);B3:J3)

 

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE
LEGGI:  #Excel - Come contare le celle presenti in un intervallo [Quick Tip]

Copyright © 2014-2017  Office Academy. Tutti i diritti riservati.
Vai alla barra degli strumenti