#Excel – Come contare le celle che contengono numeri dispari [Quick Tip]

Se avete bisogno di contare le celle che contengono solo numeri dispari, è possibile utilizzare una formula basata sulla funzione MATR.SOMMA.PRODOTTO insieme alla funzione RESTO.

Contare le celle che contengono numeri dispari

Nell’esempio mostrato, la formula nella cella E3 è:

=MATR.SOMMA.PRODOTTO(--(RESTO(B3:B8;2)=1))

Questa formula restituisce 4 dato che ci sono 4 numeri dispari nell’intervallo B3:B8.

Come funziona questa formula

La funzione MATR.SOMMA.PRODOTTO lavora direttamente con le matrici.

Una cosa potete fare abbastanza facilmente con MATR.SOMMA.PRODOTTO è eseguire un test su una matrice usando uno o più criteri, poi contare i risultati.

In questo caso, eseguiamo un test per sapere se un numero è dispari, utilizzando la funzione RESTO:

RESTO(B3:B8;2)=1

RESTO restituisce il resto dopo la divisione. In questo caso, il divisore è 2, così RESTO restituirà un resto di 1 per ogni intero dispari, e un resto di zero per i numeri pari.

All’interno di MATR.SOMMA.PRODOTTO, questo test viene eseguito su ogni cella dell’intervallo B3:B8, il risultato è una matrice di valori VERO/FALSO:

{FALSO.VERO.VERO.VERO.FALSO.VERO}

Poi trasformiamo i valori VERO/FALSO in numeri utilizzando il doppio negativo (doppio unario: ), così abbiamo:

{0.1.1.1.0.1}

MATR.SOMMA.PRODOTTO poi semplicemente somma questi numeri e restituisce 4.

 

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE

LEGGI:  #Excel - Come trovare il valore più piccolo con criteri
Copyright © 2014-2017  Office Academy. Tutti i diritti riservati.
Vai alla barra degli strumenti