#Excel – Come contare le celle che non contengono errori [Quick Tip]

Se avete bisogno di contare il numero di celle che non contengono errori, è possibile utilizzare le funzioni VAL.ERRORE e NON, racchiuse nella funzione MATR.SOMMA.PRODOTTO.

Contare celle che non contengono errori

Nell’esempio, la cella attiva contiene questa formula:

=MATR.SOMMA.PRODOTTO(--NON(VAL.ERRORE(B3:B7)))

Come funziona questa formula

MATR.SOMMA.PRODOTTO accetta una o più matrici e calcola la somma dei prodotti dei numeri corrispondenti. Se viene fornita una sola matrice, essa somma semplicemente gli elementi della matrice.

La funzione VAL.ERRORE viene valutata per ogni cella dell’intervallo (B3:B7). Senza la funzione NON, il risultato è una matrice di valori VERO o FALSO:

{VERO.FALSO.VERO.FALSO.FALSO}

Con la funzione NON, il risultato è:

{FALSO.VERO.FALSO.VERO.VERO}

I valori VERO corrispondono alle celle che non contengono errori al loro interno.

L’operatore — (chiamato “doppio unario”) trasforma i valori VERO/FALSO in 1 e zero. La matrice risultante sarà quindi simile alla seguente:

{0.1.0.1.1}

MATR.SOMMA.PRODOTTO quindi somma gli elementi di questa matrice e restituisce il totale, che nell’esempio è il numero 3.

Potete anche utilizzare la funzione SOMMA per contare gli errori. La struttura della formula è la stessa, ma deve essere immessa come formula matriciale (premendo Ctrl + Maiusc + Invio invece di solo Invio). Una volta inserita, la formula sarà simile a questa:

{=SOMMA(--NON(VAL.ERRORE(B3:B7)))}

Non immettete le parentesi graffe {}, esse vengono immesse da Excel quando si preme Ctrl + Maiusc + Invio.

 

LEGGI:  #Excel - Come calcolare una media escludendo i due valori più piccoli
Copyright © 2014-2017  Office Academy. Tutti i diritti riservati.
Vai alla barra degli strumenti