#Excel – Come sommare gli n valori più alti o più bassi

Se avete bisogno di sommare i valori più alti o più bassi in un intervallo, è possibile farlo con una formula che utilizzi alternativamente la funzione GRANDE o PICCOLO racchiuse all’interno della funzione MATR.SOMMA.PRODOTTO.

Sommare gli n valori più alti o più bassi

Sommare gli n valori più alti

Nell’esempio, la cella attiva contiene questa formula:

=MATR.SOMMA.PRODOTTO(GRANDE(B3:B12;{1.2.3}))

Come funziona questa formula

Nella sua forma più semplice, la funzione GRANDE restituisce l’n-esimo più grande valore in un intervallo. Ad esempio, la formula:

=GRANDE(B3:B12; 2)

restituirà il secondo valore più grande nell’intervallo B3:B12, che, nell’esempio qua sopra, è il numero 9.

Tuttavia, se, come secondo argomento della funzione, forniamo a GRANDE una “costante di matrice” (ad esempio, una costante nella forma {1.2.3}), GRANDE restituirà una serie di risultati, invece di un singolo risultato. Così, la formula:

=GRANDE(B3:B12;{1.2.3})

Restituirà il 1°, il 2° e il 3° valore più grande dell’intervallo B3:B12. Nel precedente esempio, dove B3:B12 contiene i numeri 1-10, il risultato restituito da GRANDE sarà la matrice {8.9.10}. MATR.SOMMA.PRODOTTO poi sommerà i numeri in questa matrice e restituirà il totale, che è 27.

Utilizzare MATR.SOMMA.PRODOTTO evita la complessità di inserire una formula matriciale, pur lavorando anch’essa con le matrici. È però possibile scrivere una formula matriciale direttamente utilizzando la funzione SOMMA:

{=SOMMA(GRANDE(B3:B12;{1.2.3}))}

Questa formula va però inserita come formula matriciale, senza le parentesi graffe e premendo contemporaneamente i tasti Ctrl + Maiusc + Invio.

Quando n diventasse troppo grande, rendendo quindi noioso il lavoro di creare la costante di matrice a mano (ad esempio se si dovesse sommare i 20 o 30 valori più grandi di un elenco di grandi dimensioni), è possibile utilizzare uno stratagemma che costruisce la costante di matrice utilizzando le funzioni RIF.RIGA e INDIRETTO.

LEGGI:  #Excel - Corrispondenza esatta con MATRICE.SOMMA.PRODOTTO

Per esempio, se doveste sommare i 20 valori più alti in un intervallo chiamato “rng” è possibile scrivere una formula come questa:

=MATR.SOMMA.PRODOTTO(GRANDE(rng;RIF.RIGA(INDIRETTO("1:20"))))

Sommare gli n valori più bassi

Tutte le formule utilizzate per sommare gli n valori più alti possono essere sfruttate anche per sommare gli n valori più bassi, è sufficiente sostituire alla funzione GRANDE la funzione PICCOLO.

 

Copyright © 2014-2017  Office Academy. Tutti i diritti riservati.
Vai alla barra degli strumenti