#Excel – Corrispondenza esatta con INDICE e CONFRONTA

Come effettuare una ricerca che tenga conto del maiuscolo o minuscolo

Per impostazione predefinita, le ricerche standard con CERCA.VERT o INDICE + CONFRONTA non tengono conto del maiuscolo o minuscolo. Sia CERCA.VERT che CONFRONTA restituiscono semplicemente la prima corrispondenza, ignorando le maiuscole.

Tuttavia, se avete bisogno di fare una ricerca tra maiuscole e minuscole, è possibile farlo con una formula matriciale che utilizza le funzioni INDICE, CONFRONTA e IDENTICO.

Effettuare ricerche case sensitive

Nell’esempio, stiamo usando la seguente formula

{=INDICE(Dati;CONFRONTA(VERO;IDENTICO(F4;B3:B12);0);3)}

Questa formula è una formula matriciale e va inserita con Ctrl + Maiusc + Invio.

Come funziona questa formula

Dal momento che CONFRONTA da sola non è case sensitive, abbiamo bisogno di un sistema per fare in modo che Excel tenga in considerazione le maiuscole. La funzione IDENTICO è la funzione perfetta per questo, ma la usiamo in modo inconsueto, in quanto abbiamo bisogno di confrontare una cella con un intervallo di celle.

Analizzando la formula dall’interno verso l’esterno, prima abbiamo:

IDENTICO(F4;B3:B12)

dove F4 contiene il valore di ricerca, e B3:B12 è il riferimento alla colonna di ricerca (Nome). Poiché come secondo argomento della funzione IDENTICO stiamo fornendo un intervallo, IDENTICO restituirà una matrice di valori VERO o FALSO come questa:

{FALSO.FALSO.FALSO.FALSO.FALSO.VERO.FALSO.FALSO.FALSO.FALSO}

Questo è il risultato del confronto tra il valore nella cella B4 e ogni cella della colonna di ricerca. Ovunque vediamo VERO, sappiamo di avere una corrispondenza esatta che rispetta le maiuscole.

Ora abbiamo bisogno di ottenere la posizione (cioè il numero di riga) del valore VERO di questa matrice. Per questo, possiamo utilizzare la funzione CONFRONTA impostata per ottenere una corrispondenza esatta della ricerca di VERO:

CONFRONTA(VERO;IDENTICO(F4;B3:B12);0)

È importante notare che CONFRONTA restituisce sempre la prima corrispondenza, pertanto, nel caso ci fossero dei duplicati, otterrete solo e sempre il primo valore.

LEGGI:  #Excel – Come usare la formattazione condizionale di Excel – Parte 5

Ora abbiamo un numero di riga. Ora, abbiamo solo bisogno di usare INDICE per recuperare il valore all’intersezione tra la riga trovata e la colonna che forniamo. Il numero di colonna in questo caso è codificata come 3, poiché l’intervallo denominato “Dati” include tutte le colonne. La formula finale è:

{=INDICE(Dati;CONFRONTA(VERO;IDENTICO(F4;B3:B12);0);3)}

Dobbiamo inserire questa formula come formula matriciale a causa della matrice creata da IDENTICO.

Questa formula funziona per recuperare sia testo che valori numerici. Se volete recuperare solo numeri, è possibile utilizzare una formula basata sulla funzione MATR.SOMMA.PRODOTTO.

 

Copyright © 2014-2017  Office Academy. Tutti i diritti riservati.
Vai alla barra degli strumenti