#Excel – Come calcolare la media dei primi 3 punteggi [Quick Tip]

Per ottenere la media dei primi 3 punteggi in un insieme di dati, è possibile utilizzare una formula basata sulla funzione GRANDE.

Calcolare la media dei primi 3 punteggi

Nell’esempio mostrato, la formula in I5 è:

=MEDIA(GRANDE(C5:G5;{1.2.3}))

Come funziona questa formula

La funzione GRANDE può recuperare il k-esimo valore migliore da un insieme di valori. Così, per esempio GRANDE(A1:A10;1) restituirà il valore più alto, GRANDE(A1:A10;2) restituirà il 2° valore più alto, e così via.

In questo caso, chiediamo più di un valore alla funzione GRANDE passandogli come secondo argomento la costante di matrice {1.2.3}. Questo fa sì che GRANDE restituisca come risultato una matrice che includa i 3 valori più alti. La funzione MEDIA restituisce la media di questi valori.

La funzione MEDIA è programmata per gestire automaticamente i risultati sotto forma di matrice, quindi non è necessario utilizzare Ctrl + Maiusc + Invio per immettere la formula.

 

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE

LEGGI:  #Excel - Come contare i valori numerici univoci di un intervallo
Copyright © 2014-2017  Office Academy. Tutti i diritti riservati.
Vai alla barra degli strumenti